[Résolu] Chargement index forum long !

Image Toutes les questions en rapport à l'utilisation de phpbb3 uniquement .
  • Publicité

Re: Chargement index forum long !

Messagepar cyrilagri » Jeu 8 Mar 2012 13:20

J'ai supprimer le mod il me semble l'autre jour c'était ça : NV_recent_topics_1_0_5 à moins que vous parler d'un autre mod ??

Voici ce que le support monarobase.net me fait par :

En effet celui-ci va chercher plus de 10000 enregistrements soit cla liste de tous vos topics ce qui n'est pas de tout une requête normale.

Normalement il faut liimiter les requêtes en mettant LIMIT NOMBRE_DE_TOPICS à la fin de la reqûete.

Peut-être que la requête n'était pas exécuté de la même manière chez votre ancien hébergeur, par exemple à cause d'une version différente de PHP.

Il faudrait trouver le mod responsable de cette requette puis éventuellement la modifier une fois qu'on a compris pourquoi il a besoin de chercher tous les titres de tous vos topics à chaque affichage…


Cordialement.
Avatar de l’utilisateur
cyrilagri
 
Messages: 255
Enregistré le: Dim 24 Juil 2011 11:08

Re: Chargement index forum long !

Messagepar zach » Jeu 8 Mar 2012 13:52

et oui regarde le nb de "rows" sur le screen, + de 10 000 + il y en a + c'est lourd évidement ... c'est pour ça que l'image complète est utile pour analyser la requête,

Image

je pense plutot que c'est le mod qui fait apparaitre le titre des derniers topics sur l'index des forums , donc supprime le pour voir la différence

il est possible qu'il y avait des options d'optimisation de la base de donnée chez l'ancien hébergeur qui a amorti ce tps de requete, mais pour autant cette requête est lourde car mal construite, il ne faut pas la garder si elle pompe 90% du tps d'accès pour si peu

Te concernant je pense que le mieux est de passer sur le Mod Seo, qui va réécrire tes liens, et qui intégré aussi le titre du dernier topic sur l'index mais beaucoup + léger niveau requête, ce qui va globalement améliorer ton référencement et réduire le tps de la requête de 5sec à quelques millisecondes
Avatar de l’utilisateur
zach

Support phpBB Assistance
 
Messages: 1313
Enregistré le: Lun 27 Déc 2010 02:52

Re: Chargement index forum long !

Messagepar cyrilagri » Jeu 8 Mar 2012 17:42

Vous parler surement de ce mod : :arrow: 'Latest Topic Title' Version 1.0.1

Titre :

Dernier titre de sujet

Description :

Affiche dans la colonne “Dernier message” le titre du dernier sujet pour chaque forum.

A par ça je voit pas car j'ai que celui si maintenant. :clin:

Cordialement.
Avatar de l’utilisateur
cyrilagri
 
Messages: 255
Enregistré le: Dim 24 Juil 2011 11:08

Re: Chargement index forum long !

Messagepar zach » Jeu 8 Mar 2012 18:00

désinstalle pour qu'on est confirmation (si ca fait bien disparaitre la requête)
Avatar de l’utilisateur
zach

Support phpBB Assistance
 
Messages: 1313
Enregistré le: Lun 27 Déc 2010 02:52

Re: Chargement index forum long !

Messagepar cyrilagri » Jeu 8 Mar 2012 18:18

La je dit oui. :danse: donc tout désinstaller fichier par fichier .

J'ai un chargement de page très court maintenant pour la requête c'est également résolue : :arrow:

Image

Time : 0.691s | 22 Queries | GZIP : On | Memory Usage: 7.55 Mio | Explain


J'ai testé la page également : :arrow:

Image

Voilà je pense que c'est maintenant résolu pour ma part car après vérification toute les autres requête sont normale . :cool:

C'est super et je remercie tout ce qui auront participation au sujet et apporter de l'aide grand merci à phpbb-Assistance également. :clin:

Cordialement.
Avatar de l’utilisateur
cyrilagri
 
Messages: 255
Enregistré le: Dim 24 Juil 2011 11:08

Re: Chargement index forum long !

Messagepar zach » Jeu 8 Mar 2012 18:26

Comme quoi tu vois c'est pas tant le nb de mod qui compte plutot la qualité de chacun, la 1 seul suffisait à tout planter

D'autant que comme je te le disais avec le mod seo, tu peut conserver cette option car la le mod le fait trés bien sans aucune lourdeur (cf mon screen)
Avatar de l’utilisateur
zach

Support phpBB Assistance
 
Messages: 1313
Enregistré le: Lun 27 Déc 2010 02:52

Re: Chargement index forum long !

Messagepar cyrilagri » Mar 1 Mai 2012 08:08

Tout à fait mais grand merci "zach" pour le temps consacrer au problème. :clin:
Avatar de l’utilisateur
cyrilagri
 
Messages: 255
Enregistré le: Dim 24 Juil 2011 11:08

Précédente

Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invités