[Résolu] Erreur 404 dans le PCA

Image Toutes les questions en rapport à l'utilisation de phpbb3 uniquement .
  • Publicité

[Résolu] Erreur 404 dans le PCA

Messagepar boulzy » Ven 17 Fév 2012 11:08

Bonjour


Quelle version de phpBB utilisez-vous ?
Phpbb3

Quelle type et quelle version de base de données utilisez-vous ?
Mydql et phpmyadmin pour la gestion

Quel est le lien menant à votre forum ?
http://teamsoftware.herobo.com/

Quel hébergeur utilisez-vous ?
OOOwebhost http://www.000webhost.com/

Avez-vous installé votre forum par vous-même ?

Oui comme toujours

Avez-vous procédé à une mise à jour de votre forum ? Si oui, quand et laquelle ?

Non

Avez-vous procédé à une conversion de votre forum ?
Non

Avez-vous procédé à des modifications personnalisées sur votre forum ? Si oui, quand et lesquelles ?

oui dans le overall_header pour le seo meta tag et description

Avez-vous installé des MODs sur votre forum ? Si oui, quand et lesquels ?
le forum viens juste d’être installer avec le premod phpbbseo

Avez-vous installé des styles sur votre forum ? Si oui, quand et lesquels ?
j'ai un style qui fonctionne sur prosilver le thème trouver sur phpbb3styles template SEO

Avez-vous installé des archives de langue sur votre forum ? Si oui, quand et lesquels ?
la langue officiel phpbb FR

Avez-vous installé des outils sur votre forum ? Si oui, quand et lesquels ?
non

Est-il nécessaire d'être inscrit et connecté afin de reproduire et constater votre problème ?
oui en administrateur

Quel est votre niveau d'expérience ?
je débute en tant que webmaster j'ai déjas utiliser IPB , Vbulletin , Mybb , phpbb3 pour les forum
Wordpress et drupal pour les sites
je peut codé un site valide W3C et optimiser mais pas dynamique manque de connaissance en php

Depuis quand votre problème a-t-il débuté ?

Je fait le forum pour une futur entreprise et je constate le problème depuis hier

Veuillez à présent décrire de manière précise votre problème :

Alors tous fonctionne sur mon forum phpbb sauf quand je suis sur un forum et que je clique sur panneau d'administration la jai une page 404 alors que sur lindex je n'est pas ce problème pour tous le reste pas de problème
j'ai installer phpbbseo surement une modification à faire dans le fichier config et dans la bdd pour changer une url

je précise que mon forum est à la racine sans dossier et que jai mon htaccess à la racine

désoler pour mon orthographe
boulzy
 
Messages: 8
Enregistré le: Ven 17 Fév 2012 11:04

Re: Erreur 404 dans le PCA

Messagepar Steph » Ven 17 Fév 2012 11:22

Salut,

Il te maque tout simplement les modifications concernant la prémod SEO dans ton style
Avatar de l’utilisateur
Steph

Administrateur phpBB Assistance
 
Messages: 10276
Âge: 39 ans
Enregistré le: Lun 19 Avr 2010 18:25
Localisation: Alsace (67)
Hébergeur(s): monarobase

Re: Erreur 404 dans le PCA

Messagepar boulzy » Ven 17 Fév 2012 11:40

merci pour la reponse rapide sur le thème pas default c'est pareil quel modification je dois effectuer j'ai fait une installation avec le premod phpbbseo et ajouté le htaccess pour le PCA le seul problème je sais pas ce que je dois modifier et merci encore pour cette réponse
boulzy
 
Messages: 8
Enregistré le: Ven 17 Fév 2012 11:04

Re: Erreur 404 dans le PCA

Messagepar zach » Ven 17 Fév 2012 11:58

salut

à priori faut voir sur quel lien ça t’amène, car ca semble bon comme ca http://teamsoftware.herobo.com/adm/

sinon comme le dis steph, si tu change le style il faut y appliquer les modifs de style phpbb seo en principe http://www.phpbb-seo.com/fr/premod-phpb ... t2365.html à moins que ce style dit "seo" soit prévu pour la premod phpbb seo (ou alors c'est purement décoratif)
Avatar de l’utilisateur
zach

Support phpBB Assistance
 
Messages: 1313
Enregistré le: Lun 27 Déc 2010 02:52

Re: Erreur 404 dans le PCA

Messagepar boulzy » Ven 17 Fév 2012 12:03

http://teamsoftware.herobo.com/reglemen ... 5777c40bc7

sur le forum quand je clique en bas de page sur le pca

et quand sa fonctionne sur lindex l'url : http://teamsoftware.herobo.com/adm/inde ... 5777c40bc7
boulzy
 
Messages: 8
Enregistré le: Ven 17 Fév 2012 11:04

Re: Erreur 404 dans le PCA

Messagepar Steph » Ven 17 Fév 2012 12:08



Vu ce lien je te confirme qu'il te manque les bouts de code dans ton style ni plus ni moins et le fait que ça fasse pareil avec ton prosilver n'y change rien
Avatar de l’utilisateur
Steph

Administrateur phpBB Assistance
 
Messages: 10276
Âge: 39 ans
Enregistré le: Lun 19 Avr 2010 18:25
Localisation: Alsace (67)
Hébergeur(s): monarobase

Re: Erreur 404 dans le PCA

Messagepar boulzy » Ven 17 Fév 2012 12:18

Oui mais je ne vois pas ce qui manque je débute :(

voila mon htaccess




Code: Tout sélectionner
# Lines That should already be in your .htacess
<Files "config.php">
Order Allow,Deny
Deny from All
</Files>
<Files "common.php">
Order Allow,Deny
Deny from All
</Files>

# You may need to un-comment the following lines
# Options +FollowSymlinks
# To make sure that rewritten dir or file (/|.html) will not load dir.php in case it exist
# Options -MultiViews
# REMEBER YOU ONLY NEED TO STARD MOD REWRITE ONCE
RewriteEngine On
# Uncomment the statement below if you want to make use of
# HTTP authentication and it does not already work.
# This could be required if you are for example using PHP via Apache CGI.
# RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
# REWRITE BASE
RewriteBase /
# HERE IS A GOOD PLACE TO FORCE CANONICAL DOMAIN
# RewriteCond %{HTTP_HOST} !^teamsoftware\.herobo\.com$ [NC]
# RewriteRule ^(.*)$ http://teamsoftware.herobo.com/$1 [QSA,L,R=301]

# DO NOT GO FURTHER IF THE REQUESTED FILE / DIR DOES EXISTS
RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule . - [L]
#####################################################
# PHPBB SEO REWRITE RULES ALL MODES
#####################################################
# AUTHOR : dcz www.phpbb-seo.com
# STARTED : 01/2006
#################################
# FORUMS PAGES
###############
# FORUM INDEX REWRITERULE WOULD STAND HERE IF USED. "forum" REQUIRES TO BE SET AS FORUM INDEX
# RewriteRule ^forum\.html$ /index.php [QSA,L,NC]
# FORUM ALL MODES
RewriteRule ^(forum|[a-z0-9_-]*-f)([0-9]+)/?(page([0-9]+)\.html)?$ /viewforum.php?f=$2&start=$4 [QSA,L,NC]
# TOPIC WITH VIRTUAL FOLDER ALL MODES
RewriteRule ^(forum|[a-z0-9_-]*-f)([0-9]+)/(topic|[a-z0-9_-]*-t)([0-9]+)(-([0-9]+))?\.html$ /viewtopic.php?f=$2&t=$4&start=$6 [QSA,L,NC]
# TOPIC WITHOUT FORUM ID & DELIM ALL MODES
RewriteRule ^([a-z0-9_-]*)/?(topic|[a-z0-9_-]*-t)([0-9]+)(-([0-9]+))?\.html$ /viewtopic.php?forum_uri=$1&t=$3&start=$5 [QSA,L,NC]
# PHPBB FILES ALL MODES
RewriteRule ^ressources/[a-z0-9_-]+/(thumb/)?([0-9]+)$ /download/file.php?id=$2&t=$1 [QSA,L,NC]
# PROFILES THROUGH USERNAME
RewriteRule ^membre/([^/]+)/?$ /memberlist.php?mode=viewprofile&un=$1 [QSA,L,NC]
# USER MESSAGES THROUGH USERNAME
RewriteRule ^membre/([^/]+)/(topics|posts)/?(page([0-9]+)\.html)?$ /search.php?author=$1&sr=$2&start=$4 [QSA,L,NC]
# GROUPS ALL MODES
RewriteRule ^(groupe|[a-z0-9_-]*-g)([0-9]+)(-([0-9]+))?\.html$ /memberlist.php?mode=group&g=$2&start=$4 [QSA,L,NC]
# POST
RewriteRule ^post([0-9]+)\.html$ /viewtopic.php?p=$1 [QSA,L,NC]
# ACTIVE TOPICS
RewriteRule ^sujets-actifs(-([0-9]+))?\.html$ /search.php?search_id=active_topics&start=$2&sr=topics [QSA,L,NC]
# UNANSWERED TOPICS
RewriteRule ^sans-reponses(-([0-9]+))?\.html$ /search.php?search_id=unanswered&start=$2&sr=topics [QSA,L,NC]
# NEW POSTS
RewriteRule ^nouveaux-messages(-([0-9]+))?\.html$ /search.php?search_id=newposts&start=$2&sr=topics [QSA,L,NC]
# UNREAD POSTS
RewriteRule ^non-lu(-([0-9]+))?\.html$ /search.php?search_id=unreadposts&start=$2 [QSA,L,NC]
# THE TEAM
RewriteRule ^equipe\.html$ /memberlist.php?mode=leaders [QSA,L,NC]
# HERE IS A GOOD PLACE TO ADD OTHER PHPBB RELATED REWRITERULES

# FORUM WITHOUT ID & DELIM ALL MODES
# THESE THREE LINES MUST BE LOCATED AT THE END OF YOUR HTACCESS TO WORK PROPERLY
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([a-z0-9_-]+)/?(page([0-9]+)\.html)?$ /viewforum.php?forum_uri=$1&start=$3 [QSA,L,NC]
# FIX RELATIVE PATHS : FILES
RewriteRule ^.+/(style\.php|ucp\.php|mcp\.php|faq\.php|download/file.php)$ /$1 [QSA,L,NC,R=301]
# FIX RELATIVE PATHS : IMAGES
RewriteRule ^.+/(styles/.*|images/.*)/$ /$1 [QSA,L,NC,R=301]
# END PHPBB PAGES
#####################################################


mon cp
Image
Déplacer le curseur de votre souris sur l’image pour l’afficher
Cette image n’est pas hébergée via un domaine approuvé. Pour plus d’informations concernant cette limitation, consultez la FAQ, partie "Hébergement d’images externes"
boulzy
 
Messages: 8
Enregistré le: Ven 17 Fév 2012 11:04

Re: Erreur 404 dans le PCA

Messagepar zach » Ven 17 Fév 2012 12:26

boulzy a écrit:http://teamsoftware.herobo.com/reglemen ... 5777c40bc7

sur le forum quand je clique en bas de page sur le pca

et quand sa fonctionne sur lindex l'url : http://teamsoftware.herobo.com/adm/inde ... 5777c40bc7


Ok donc le 1er lien renvoi sur cette url -http://error404.000webhost.com/? (d'ailleurs bloquée par mon antivirus)
Image

pas bon : -http://teamsoftware.herobo.com/reglement/adm/index.php?sid=7c27a5c0c0d62a6cc00a755777c40bc7
bon : -http://teamsoftware.herobo.com/adm/index.php?sid=7c27a5c0c0d62a6cc00a755777c40bc7

donc tu regarde ou sont ces 2 liens dans les templates (index_body.html et viewforum_body.html), normalement ils sont plutot dans overhall_footer
Avatar de l’utilisateur
zach

Support phpBB Assistance
 
Messages: 1313
Enregistré le: Lun 27 Déc 2010 02:52

Re: Erreur 404 dans le PCA

Messagepar boulzy » Ven 17 Fév 2012 12:28

Oui mais je dois modifier sa dans l'overall_footer ?
je vois pas comment modifier l'url :(

mon overall_footer

Code: Tout sélectionner
<div id="wrapfooter">
<!-- IF U_ACP --><span class="gensmall">[ <a href="{U_ACP}">{L_ACP}</a> ]</span><br /><br /><!-- ENDIF --><br />   <br /></div>
<div id="footer"><br />   
<div class="copyright2">
boulzy
 
Messages: 8
Enregistré le: Ven 17 Fév 2012 11:04

Re: Erreur 404 dans le PCA

Messagepar zach » Ven 17 Fév 2012 12:30

boulzy a écrit:Oui mais je dois modifier sa dans l'overall_footer ?
je vois pas comment modifier l'url :(


ben montre deja le lien comme il se presente dans le template du footer
Avatar de l’utilisateur
zach

Support phpBB Assistance
 
Messages: 1313
Enregistré le: Lun 27 Déc 2010 02:52

Suivante

Retourner vers Utilisation

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invités