[Résolu] phpBB3-SEO-Premod problèmes d'url

Image Forum dédié au support des Mods ou support de la premod Seo .
  • Publicité

[Résolu] phpBB3-SEO-Premod problèmes d'url

Messagepar Chuchulain » Jeu 29 Nov 2012 05:22

Bonjour !

Je travail sur un nouveau forum pour la guilde d'un ami, j'utilise phpBB3-SEO-Premod_V_3-0-11 et je rencontre un problème d'url à différents niveaux. Il y à quelques mois j'avais exactement le même problème avec phpBB3-SEO-Premod_V_3-0-9 que j'avais fini par résoudre en modifiant une petite ligne de code en relation avec $phpbb_root_path, mais je ne me rappel plus du tout ce que j'avais fait et là je galère depuis 5 jours sans trouver de solution.

Voici l'adresse du forum que je développe : http://www.la-guilde-des-affranchis.fr

Le problème se présente de la façon suivante, quand je navigue sur le forum, que j'entre dans une catégorie, ex :
http://www.la-guilde-des-affranchis.fr/votre-premiere-categorie/
et que je clic sur un lien de mon menu, par exemple le lien Galerie, la nom de la catégorie interfère dans le root_path de phpbb et j’obtiens l'adresse suivante :
http://www.la-guilde-des-affranchis.fr/votre-premiere-categorie/gallery/index.php
à la place de :
http://www.la-guilde-des-affranchis.fr/gallery/index.php

Si c'était le seul problème je pourrais simplement modifié les liens de mon menu dans le overall_header.html du template ou encore dans le fichier includes/functions.php... Mais ce problème à d'autres conséquences, par exemple quand on est connecté, que l'on est sur la fiche de profil d'un utilisateur, que l'on clic sur le lien (Rechercher les images de l'utilisateur) on obtiens l'url suivante :
-http://www.la-guilde-des-affranchis.fr/membre/Chuchulain/gallery/search.php?user_id=2
à la place de :
-http://www.la-guilde-des-affranchis.fr/gallery/search.php?user_id=2

Il en vas de même avec les autres liens des autres modules, agenda, Mchat, portail... J'imagine que je ne suis pas le premier à qui cela arrive. J'avais déjà planché la dessus plusieurs semaine à l'époque ou j'avais développé le forum "http://www.tuatha-de-danann.fr", et la solutions était toute simple, juste une toute petite ligne à modifier dans une fonction qui gère le phpbb_root_path....

Mais j'ai beau martyriser mes neurones et explorer la toile, je ne retrouve plus la solution que j'avais appliqué, je n'ai trouvé aucune suggestion nul-part, je me rappel juste que c'était une tout petite modif de rien du tout dans une ligne de code quelque par !...
Mais où ?!...
:sky:

Un grand merci à celui ou celle qui me mettra sur la piste qui m'aideras à trouver la solution !
Chuchulain
Avatar de l’utilisateur
Chuchulain
 
Messages: 7
Âge: 46 ans
Enregistré le: Mer 2 Nov 2011 15:58

Re: phpBB3-SEO-Premod problèmes d'url

Messagepar EnYgmA » Jeu 29 Nov 2012 05:41

Salut,

Zippe moi ton fichier includes/functions.php Stp :clin:
Conditions générales de services - Conditions générales de support - C.G.U
Merci de mettre un titre de sujet explicite pour toutes vos demandes de support

Référencement gratuit - Forum informatique
Avatar de l’utilisateur
EnYgmA

Administrateur phpBB Assistance
 
Messages: 8503
Âge: 35 ans
Enregistré le: Lun 19 Avr 2010 17:44
Localisation: Lyon
Hébergeur(s): Monarobase

Re: phpBB3-SEO-Premod problèmes d'url

Messagepar Steph » Jeu 29 Nov 2012 10:19

Salut,

J'ai déjà vu ce genre de problème, regarde du côté de ton fichier overall_header.html (et les autres fichiers du style en même temps) il te manque certainement des trucs entre <head> et </head>

:clin:
Avatar de l’utilisateur
Steph

Administrateur phpBB Assistance
 
Messages: 10277
Âge: 39 ans
Enregistré le: Lun 19 Avr 2010 18:25
Localisation: Alsace (67)
Hébergeur(s): monarobase

Re: phpBB3-SEO-Premod problèmes d'url

Messagepar Chuchulain » Jeu 29 Nov 2012 17:31

Salut ;)

Merci pour la rapidité de vos réponses, je cherche encore !
hmmmm

Je viens de tester avec le template prosilver et il n'y as pas ce bug... donc il dois bien y avoir un truc qui cloche dans mon header...
Je vais voir ça ce soir et je vous tiens au jus !
Encore merci !
:grin:

-----------------------------[Édition :]-----------------------------
Résolut !
Le problème étais bien dans le overall_header.html, j'avais juste oublié de mettre {SEO_BASE_HREF} juste après la balise <head> !
:danse:

Un grand merci à vous !
Chuchulain
Avatar de l’utilisateur
Chuchulain
 
Messages: 7
Âge: 46 ans
Enregistré le: Mer 2 Nov 2011 15:58

Re: phpBB3-SEO-Premod problèmes d'url

Messagepar Steph » Jeu 29 Nov 2012 17:39

:cool:
Avatar de l’utilisateur
Steph

Administrateur phpBB Assistance
 
Messages: 10277
Âge: 39 ans
Enregistré le: Lun 19 Avr 2010 18:25
Localisation: Alsace (67)
Hébergeur(s): monarobase


Retourner vers Forum Seo

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invités