[Support] Galerie phpBB

Image Forum de support des mod's .
Image Demande de personnalisation interdite
Verrouillé

fred35
Messages : 22
Enregistré le : 21 décembre 2011
Hébergeur(s) : olympe network

Re: [Support] Galerie phpBB 1.1.4

Message par fred35 »

Code : Tout sélectionner

Fatal error: Class 'phpbb_gallery_auth' not found in /dns/com/olympe-network/fred35/phpBB3/includes/gallery/gallery.php on line 72
quand je clic sur le bouton gallery
avez vous une idée?
Avatar du membre

EnYgmA
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 8662
Enregistré le : 19 avril 2010
Hébergeur(s) : Monarobase
Localisation : Au soleil
Contact :

Re: [Support] Galerie phpBB 1.1.4

Message par EnYgmA »

Miom :Peace:

Si oui, envoie moi tes fichiers que je regarde :clin:
Très absent en ce moment ...
Conditions générales de services - Conditions générales de support - C.G.U
Merci de mettre un titre de sujet explicite pour toutes vos demandes de support
Référencement gratuit - Forum informatique

fred35
Messages : 22
Enregistré le : 21 décembre 2011
Hébergeur(s) : olympe network

Re: [Support] Galerie phpBB 1.1.4

Message par fred35 »

tu veu que je t' envoi quel fichier?
Avatar du membre

EnYgmA
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 8662
Enregistré le : 19 avril 2010
Hébergeur(s) : Monarobase
Localisation : Au soleil
Contact :

Re: [Support] Galerie phpBB 1.1.4

Message par EnYgmA »

tous ceux que le mod demande d'encoder :clin:
Très absent en ce moment ...
Conditions générales de services - Conditions générales de support - C.G.U
Merci de mettre un titre de sujet explicite pour toutes vos demandes de support
Référencement gratuit - Forum informatique

fred35
Messages : 22
Enregistré le : 21 décembre 2011
Hébergeur(s) : olympe network

Re: [Support] Galerie phpBB 1.1.4

Message par fred35 »

Avatar du membre

EnYgmA
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 8662
Enregistré le : 19 avril 2010
Hébergeur(s) : Monarobase
Localisation : Au soleil
Contact :

Re: [Support] Galerie phpBB 1.1.4

Message par EnYgmA »

Bon c'est parti :Peace:

Ouvrir : viewonline.php

Chercher :

Code : Tout sélectionner

preg_match('#^([a-z0-9/_-]+)#i', $row['session_page'], $on_page);
	if (!sizeof($on_page))
	{
		$on_page[1] = '';
	}
Ajouter après :

Code : Tout sélectionner

	// phpBB Gallery integration
	if (class_exists('phpbb_gallery_integration'))
	{
		phpbb_gallery_integration::viewonline_pre_switch($on_page, $row['session_page']);
	}
Ouvrir : includes / constants.php

Chercher :

Code : Tout sélectionner

define('LOG_USERS', 3);
Ajouter après :

Code : Tout sélectionner

define('LOG_GALLERY', 4);
Ouvrir : includes / functions_user.php

Chercher :

Code : Tout sélectionner

	$sql = 'DELETE FROM ' . USER_GROUP_TABLE . "
		WHERE group_id = $group_id
			AND " . $db->sql_in_set('user_id', $user_id_ary);
	$db->sql_query($sql);

	// Clear permissions cache of relevant users
	$auth->acl_clear_prefetch($user_id_ary);
Ajouter après :

Code : Tout sélectionner

	if (class_exists('phpbb_gallery_integration'))
	{
		phpbb_gallery_integration::group_user_del($group_id, $user_id_ary);
	}
:!: Il est demandé de trouver

Code : Tout sélectionner

		if (in_array($config['newest_user_id'], $user_id_ary))
		{
			set_config('newest_user_colour', $sql_ary['user_colour'], true);
		}
	}
Pour ajouter après !

Code : Tout sélectionner

	if (class_exists('phpbb_gallery_integration'))
	{
		phpbb_gallery_integration::group_set_user_default($user_id_ary, $sql_ary);
	}
tu as collé le code là où il ne fallait pas !

Code : Tout sélectionner

if (in_array($config['newest_user_id'], $user_id_ary))
		{
			set_config('newest_user_colour', $sql_ary['user_colour'], true);
if (class_exists('phpbb_gallery_integration'))
	{
		phpbb_gallery_integration::group_set_user_default($user_id_ary, $sql_ary);
	}
		}
	}
Ouvrir : includes / session.php

Chercher :

Code : Tout sélectionner

$sql_ary = array('session_time' => $this->time_now, 'session_last_visit' => $this->time_now, 'session_admin' => 0);
$sql_ary['session_album_id'] = $this->page['album'];

					if ($this->update_session_page)
					{
						$sql_ary['session_page'] = substr($this->page['page'], 0, 199);
						$sql_ary['session_forum_id'] = $this->page['forum'];
Remplacer par :

Code : Tout sélectionner

$sql_ary = array('session_time' => $this->time_now, 'session_last_visit' => $this->time_now, 'session_admin' => 0);

					if ($this->update_session_page)
					{
						$sql_ary['session_page'] = substr($this->page['page'], 0, 199);
						$sql_ary['session_forum_id'] = $this->page['forum'];
						$sql_ary['session_album_id'] = $this->page['album'];
Ouvrir : includes / acp / acp_styles.php

Et revoir la modification car tu as oublié de laisser un espace à la fin du code ! :clin:


Ouvrir : includes / acp / info / acp_logs.php

Chercher :

Code : Tout sélectionner

'critical'	=> array('title' => 'ACP_CRITICAL_LOGS', 'auth' => 'acl_a_viewlogs', 'cat' => array('ACP_FORUM_LOGS')),
Ajouter après :

Code : Tout sélectionner

'gallery'	=> array('title' => 'ACP_GALLERY_LOGS', 'auth' => 'acl_a_viewlogs', 'cat' => array('ACP_FORUM_LOGS')),
Ouvrir : styles / prosilver / template / viewtopic_body.html

Chercher :

Code : Tout sélectionner

<!-- IF postrow.U_JABBER --><li class="jabber-icon"><a href="{postrow.U_JABBER}" onclick="popup(this.href, 550, 320); return false;" title="{L_JABBER}"><span>{L_JABBER}</span></a></li><!-- ENDIF -->
Ajouter après :

Code : Tout sélectionner

<!-- IF postrow.U_GALLERY --><li class="gallery-icon"><a href="{postrow.U_GALLERY}" title="{L_PERSONAL_ALBUM}"><span>{L_PERSONAL_ALBUM}</span></a></li><!-- ENDIF -->

viewtopic.php :arrow: Non présent dans l'archive
includes / cache.php :arrow: Non présent dans l'archive

Au passage prends l'habitude de respecter les syntaxes de code, tu poses ça en vrac :na:
ca va me prendre 1 heure !
moitié moins exactement, et si tu faisais plus attention à ce que tu poses tu ne serais pas là à attendre que je te dise tes erreurs ... :clin:
Très absent en ce moment ...
Conditions générales de services - Conditions générales de support - C.G.U
Merci de mettre un titre de sujet explicite pour toutes vos demandes de support
Référencement gratuit - Forum informatique

fred35
Messages : 22
Enregistré le : 21 décembre 2011
Hébergeur(s) : olympe network

Re: [Support] Galerie phpBB 1.1.4

Message par fred35 »

merci beaucoup ca fonctione!!

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 12075
Enregistré le : 19 avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: [Support] Galerie phpBB 1.1.4

Message par Steph »

Je ne vois pas d'erreur dans le code donné donc revois les modifications car tu as surement placé du code au mauvais endroit, le plus simple serai de repartir d'une sauvegarde de ton fichier et de recommencer

Ou post ton fichier ici et donne le lien ---> http://code.empreintesduweb.com/

fred35
Messages : 22
Enregistré le : 21 décembre 2011
Hébergeur(s) : olympe network

Re: [Support] Galerie phpBB 1.1.4

Message par fred35 »

merci toutes ces modifs ont regle mon probleme :cool:

fred35
Messages : 22
Enregistré le : 21 décembre 2011
Hébergeur(s) : olympe network

Re: [Support] Galerie phpBB 1.1.4

Message par fred35 »

jai de nouveau un probleme
lorsque japuie sur gallery sa me deconecte en me disant que ya pas de galerie :mouh: :clin:
Verrouillé

Retourner vers « Support Mods Bdd »