Chargement index forum long !

Image Toutes les questions en rapport à l'utilisation de phpbb3 uniquement .
Avatar du membre

Auteur du sujet
cyrilagri
Messages : 255
Enregistré le : juillet 2011

Re: Chargement index forum long !

Message par cyrilagri » mer. 7 mars 2012 19:31

Voici un résultat après activation du debug:
afficher en bas du forum : :arrow:
Time : 5.341s | 33 Queries | GZIP : Off | Memory Usage: 7.56 Mio | Explain

afficher en haut du forum: :arrow:
[phpBB Debug] PHP Notice: in file [ROOT]/index.php on line 112: Undefined index: user_email
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4948: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3822)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4950: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3822)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4951: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3822)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4952: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3822)
C'est quoi le problème la . hmmmm

Avatar du membre

zach
Support phpBB Assistance
Support phpBB Assistance
Messages : 1313
Enregistré le : décembre 2010

Re: Chargement index forum long !

Message par zach » mer. 7 mars 2012 19:51

Vu que le jaune est enorme seulement sur le fichier d'index (et pas sur les autres de la liste des requetes) j'en déduirais que c'est lié aux requetes effectuées par la base de donnée du serveur, soit elle est lente (voir les options d'optimisations de la base) soit quelle est normale mais que les requêtes pompent pas mal,
Time : 5.341s | 33 Queries | GZIP : Off
à titre d'exemple sur mon forum qui pourtant a beaucoup de mods (mais pas n'importe lesquels) 50% de requêtes SQL en +, malgrès ca c'est 20 fois plus rapide ... Image

deja tu dois corriger les bugs :
[phpBB Debug] PHP Notice: in file [ROOT]/index.php on line 112: Undefined index: user_email
tu dois avoir un mod en rapport qui t'a amené ce bug
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4948: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3822)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4950: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3822)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4951: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3822)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4952: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3822)
tu dois avoir des fichiers pas encodé correctement (utf8 sans bom)

Ensuite deja tu activera l'option gzip (dans l'acp, parametre serveur ou charge c'est pas compliqué à trouver) pour accelerer tout ca

et ira sur le lien en bas du forum qui apparaitra "explain" pour voir chaque requete dans le détail niveau pompage de tps

Avatar du membre

Auteur du sujet
cyrilagri
Messages : 255
Enregistré le : juillet 2011

Re: Chargement index forum long !

Message par cyrilagri » mer. 7 mars 2012 20:08

Je clique sur explain j'ai ça : :arrow:
[phpBB Debug] PHP Notice: in file [ROOT]/index.php on line 258: Undefined index: rt_index
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4948: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3822)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4950: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3822)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4951: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3822)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4952: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3822)
Oui pour ce code j'ai ce mod il me semble :http://www.lefty74.com/viewtopic.php?f=51&t=406#p2475
[phpBB Debug] PHP Notice: in file [ROOT]/index.php on line 112: Undefined index: user_email
Pour tout ça erreur corrigé j'examine le fichier Explain et je vous tient au courant. :^^:

Avatar du membre

zach
Support phpBB Assistance
Support phpBB Assistance
Messages : 1313
Enregistré le : décembre 2010

Re: Chargement index forum long !

Message par zach » mer. 7 mars 2012 20:12

Le lien n'est visible que du cpte admin faudra trouver autre chose, comme des screens

Avatar du membre

Auteur du sujet
cyrilagri
Messages : 255
Enregistré le : juillet 2011

Re: Chargement index forum long !

Message par cyrilagri » mer. 7 mars 2012 20:38

Voici au mieux en image : :arrow:

Image

Donc la requête la plus lourde !

Bon maintenant ou et l'erreur. hmmmm

Merci pour tous.

Cordialement. :clin:

Avatar du membre

zach
Support phpBB Assistance
Support phpBB Assistance
Messages : 1313
Enregistré le : décembre 2010

Re: Chargement index forum long !

Message par zach » mer. 7 mars 2012 20:46

écoute ce qui plante tout c'est surtout cette requête :

Image

Avatar du membre

Auteur du sujet
cyrilagri
Messages : 255
Enregistré le : juillet 2011

Re: Chargement index forum long !

Message par cyrilagri » mer. 7 mars 2012 20:53

A oui d'accord mais ça vient de quoi cette requête ? c'est quoi la méthode ! :clin: grand merci Zach pour l'aide fournie. :^^:

Avatar du membre

zach
Support phpBB Assistance
Support phpBB Assistance
Messages : 1313
Enregistré le : décembre 2010

Re: Chargement index forum long !

Message par zach » mer. 7 mars 2012 21:08

chez moi ca donne plutot :

Image

combien à tu fait des forums et sous forums en tout pour info ?

Avatar du membre

Auteur du sujet
cyrilagri
Messages : 255
Enregistré le : juillet 2011

Re: Chargement index forum long !

Message par cyrilagri » mer. 7 mars 2012 21:50

76 environ tout compris forum et sous forum mais ça marcher très bien avant . :^^:
Édite

Eux j'ai réussie il y à 5 minute à voir ce résultat pour la même chose donner si dessus :

Image

Time : 0.525s | 22 Queries | GZIP : On | Memory Usage: 7.6 Mio | Explain

La je comprends plus rien j'ai rien toucher et c'est rapide. :na na:

Et puis 5 minute après c'est plus long pour rien : :roo:

Time : 4.627s | 22 Queries | GZIP : On | Memory Usage: 7.6 Mio | Explain
Cordialement.

Avatar du membre

zach
Support phpBB Assistance
Support phpBB Assistance
Messages : 1313
Enregistré le : décembre 2010

Re: Chargement index forum long !

Message par zach » jeu. 8 mars 2012 13:16

ca aurait été bien l'image complète pour comparer ... la on peut pas savoir

bon deja d'avoir réglé les bugs, et activer gzip ca peut aider ....

ensuite je serais pas étonné que tes 4 sec soit un des mods réputés pour leurs lourdeur (genre dernier titre de topic sur l'index), essaye sans pour voir le détail

parceque si c'est le cas, je pense qu'il vaudrait mieux passer par le mod seo (comme moi) beaucoup + léger

Verrouillé

Retourner vers « Utilisation »