phpBB 3.1 "Ascraeus" exige PHP 5.3.2

Image Forum de discussion phpBB
Image Pas de support dans ce forum .
Répondre
     
Avatar du membre

Auteur du sujet
EnYgmA
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 8645
Enregistré le : avril 2010
Hébergeur(s) : Monarobase
Localisation : Lyon
Contact :

phpBB 3.1 "Ascraeus" exige PHP 5.3.2

Message par EnYgmA » mar. 1 mai 2012 09:08

La prochaine version majeure de phpBB, phpBB 3.1 "Ascraeus", nécessitera PHP 5.3.2 ou plus récent.

PHP 5.3 fournit des fonctionnalités importantes qu'un certain nombre de projets mis en place en ont besoin. Comme le but de phpBB est d'utiliser des composants provenant d'autres projets lorsque cela a un sens, ce qui soulève la version de PHP au moins à 5,3. Ce qui permet à phpBB de réutiliser certains composants de Symfony lieu de réimplémenter une fonctionnalité équivalente. Cela permettra d'accélérer l'achèvement de 3,1 phpBB en réduisant la quantité de travail que l'équipe de développement a à faire.

Vous pouvez lire la discussion qui a abouti à la décision.

Toutes les distributions majeures sont déjà sous PHP 5.3.2 ou plus récent dans leurs actuelles versions stables. Vous pouvez trouver un tableau de plusieurs distributions et les versions qu'ils expédient ici.

phpBB 3.0 "Olympus" continuera d'exiger PHP 4.3.3 minimum.

3.0.10 de phpBB supporte PHP 5.3. Depuis PHP 5.2 n'est plus maintenu par les développeurs PHP, les utilisateurs qui ne sont pas déjà à jour dans leur version sont fortement encouragés à passer à PHP 5.3.

Comme phpBB 3.1 "Ascraeus" est encore en développement actif, il reste encore beaucoup de temps pour mettre à jour votre installation PHP.

En outre, il convient de noter que cette annonce ne signifie pas que 3,1 phpBB verra de grandes portions de code réécrites afin de tirer parti des nouvelles fonctionnalités de PHP 5.3. Au lieu de cela, des sections de code seront mises à jour au besoin des cycles de publication 3.x.

Source: phpBB 3.1 "Ascraeus" to require PHP 5.3.2 - Oleg Development Team phpbb.com
Conditions générales de services - Conditions générales de support - C.G.U
Merci de mettre un titre de sujet explicite pour toutes vos demandes de support
Référencement gratuit - Forum informatique

Avatar du membre

Auteur du sujet
EnYgmA
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 8645
Enregistré le : avril 2010
Hébergeur(s) : Monarobase
Localisation : Lyon
Contact :

Re: phpBB 3.1 "Ascraeus" exige PHP 5.3.3

Message par EnYgmA » ven. 16 nov. 2012 04:57

Nous avons décidé de modifier légèrement la version requise pour notre prochaine version majeure, phpBB 3.1 "Ascraeus", celle ci nécessitera PHP 5.3.3 ou plus récent.

Selon l'annonce précédente, nous avions l'intention d'introduire des composants dans cette 3ème partie de phpBB, et donc annoncé l'augmentation minimale de PHP 5.3.2. Cependant, Symfony a actualisé son exigence minimale peu de temps après.

Notre code repose maintenant sur les modifications apportées après l'augmentation de l'exigence de version.

Le débat qui a conduit à cette décision peut être consulté sur Area51.

Toutes les distributions majeures sont déjà envoyées sous PHP 5.3.3 ou plus récent dans leurs versions actuelles stables.

Source: phpBB 3.1 "Ascraeus" to require PHP 5.3.2 - MichaelC Website Team Member of phpBB.com
Conditions générales de services - Conditions générales de support - C.G.U
Merci de mettre un titre de sujet explicite pour toutes vos demandes de support
Référencement gratuit - Forum informatique


cisse
Messages : 118
Enregistré le : novembre 2011
Localisation : Rezé

Re: phpBB 3.1 "Ascraeus" exige PHP 5.3.2

Message par cisse » ven. 16 nov. 2012 19:51

Bonjour,

Excusez moi d'avance si on peut pas poster à la suite, mais quand sera disponible la version majeure, phpBB 3.1 "Ascraeus" ?

Merci à vous

Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10863
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: phpBB 3.1 "Ascraeus" exige PHP 5.3.2

Message par Steph » ven. 16 nov. 2012 20:33

Salut,

Pas de date à donner désolé

Avatar du membre

Auteur du sujet
EnYgmA
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 8645
Enregistré le : avril 2010
Hébergeur(s) : Monarobase
Localisation : Lyon
Contact :

Re: phpBB 3.1 "Ascraeus" exige PHP 5.3.2

Message par EnYgmA » ven. 16 nov. 2012 20:33

Salut,

aucune date pour le moment, les développeurs eux mêmes ne le savent pas :clin:
Conditions générales de services - Conditions générales de support - C.G.U
Merci de mettre un titre de sujet explicite pour toutes vos demandes de support
Référencement gratuit - Forum informatique

Répondre
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Retourner vers « Forum phpBB »