[Rules_page-V 1_0_1]Problème trouver via debug phpbb !

Image Demande de support pour les mods indépendants de la base .
Règles du forum
Merci de respecter les règles de la section pour les titres :

[Nom du mod - Version] Description du problème .
Verrouillé
     
Avatar du membre

Auteur du sujet
cyrilagri
Messages : 255
Enregistré le : juillet 2011

[Rules_page-V 1_0_1]Problème trouver via debug phpbb !

Message par cyrilagri » mar. 10 avr. 2012 16:31

Bonjour,

j'ai activer le système debug phpbb !

J'ai cette erreur seulement ça vient de ce mod Rules_page_1_0_1 mais je voit pas comment la supprimer après plusieurs test ! hmmmm

Code : Tout sélectionner

[phpBB Debug] PHP Notice: in file [ROOT]/faq.php on line 77: Undefined offset: 1
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4947: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3822)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4949: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3822)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4950: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3822)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4951: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3822)
Merci cordialement. :clin:


ZePhYmA

Re: Debug phpbb !

Message par ZePhYmA » mar. 10 avr. 2012 19:12

Bonsoir,
Image
Information
-- Topic déplacé par ZePhYmA dans le bon forum --
Vous dîtes que cela provient d'un module, je déplace, en conséquence, vers la plateforme adéquate.
Suite à ce déplacement, merci de modifier le titre pour lui attribuer un format plus indiqué : [Nom du mod - Version] Description du problème .

Cordialement,

Avatar du membre

Auteur du sujet
cyrilagri
Messages : 255
Enregistré le : juillet 2011

Re: [Rules_page-V 1_0_1]Problème trouver via debug phpbb !

Message par cyrilagri » mar. 10 avr. 2012 19:19

Merci beaucoup désoler :roo: j’étaie entraine de vouloir déplacer et de modifier le titre quand je me suis aperçu que ça avez déjà était fait merci. :clin:

Avatar du membre

zach
Support phpBB Assistance
Support phpBB Assistance
Messages : 1313
Enregistré le : décembre 2010

Re: [Rules_page-V 1_0_1]Problème trouver via debug phpbb !

Message par zach » mar. 10 avr. 2012 19:21

salut

apparemment le prb se trouve dans faq.php ligne 77

Avatar du membre

Auteur du sujet
cyrilagri
Messages : 255
Enregistré le : juillet 2011

Re: [Rules_page-V 1_0_1]Problème trouver via debug phpbb !

Message par cyrilagri » mar. 10 avr. 2012 20:42

Oui mais je voit pas trop quoi voici le bouts de code de la ligne 35 à 80 : :clin:
-- Message édité par ZePhYmA - Raison: Retrait du code car celui-ci faisait plus de 20 lignes.
Voici le fichier en ZIP :

Pass : test


fichier zip: faq.zip

Merci beaucoup. :^^:


ZePhYmA

Re: [Rules_page-V 1_0_1]Problème trouver via debug phpbb !

Message par ZePhYmA » mar. 10 avr. 2012 20:44

Je me suis également permis de supprimer le code de votre message car celui-ci faisait plus de 20 lignes.
Est spécifié dans les conditions générales de support qu'un code ne doit pas composer plus de 20 lignes.

Le fichier que vous venez de fournir un téléchargement ci-dessus devrait suffire.

Merci de votre compréhension,

Avatar du membre

Auteur du sujet
cyrilagri
Messages : 255
Enregistré le : juillet 2011

Re: [Rules_page-V 1_0_1]Problème trouver via debug phpbb !

Message par cyrilagri » mer. 11 avr. 2012 18:58

Bonjour, ça serait tout simplement pas le système debug qui fait n'importe quoi . :euh:

J'ai regarde le fichier faq.php rien à dire tout et bon !! (vérifier sur chaque mod et au fichier original)= donc ligne 77 je voit pas.

j'ai aussi regarder ligne 3815 du fichier includes/includes_fonction.php

Code : Tout sélectionner

echo '<b>[phpBB Debug] ' . $error_name . '</b>: in file <b>' . $errfile . '</b> on line <b>' . $errline . '</b>: <b>' . $msg_text . '</b><br />' . "\n";
Et cette ligne correspond à debug. :na na:

Cordialement.

Avatar du membre

zach
Support phpBB Assistance
Support phpBB Assistance
Messages : 1313
Enregistré le : décembre 2010

Re: [Rules_page-V 1_0_1]Problème trouver via debug phpbb !

Message par zach » mer. 11 avr. 2012 19:15

cyrilagri a écrit : Bonjour, ça serait tout simplement pas le système debug qui fait n'importe quoi . :euh:

J'ai regarde le fichier faq.php rien à dire tout et bon !! (vérifier sur chaque mod et au fichier original)= donc ligne 77 je voit pas.
a quoi tu a vu que tout était bon ? tu a vu ce qu'il y a ligne 77 ?

Code : Tout sélectionner

$help_ary[0] = $dl_faq->dl_faq_format($help_ary[0]);
	$help_ary[1] = $dl_faq->dl_faq_format($help_ary[1]);
tu a vérifié si c'était d'origine sur phpbb ? ou si ca avait été ajouté genre par un mod download ?

Avatar du membre

Auteur du sujet
cyrilagri
Messages : 255
Enregistré le : juillet 2011

Re: [Rules_page-V 1_0_1]Problème trouver via debug phpbb !

Message par cyrilagri » mer. 11 avr. 2012 19:37

Si justement c'est deux ligne vienne du mod téléchargement ,mais j'ai vérifier avec ou sans donc de base c'est pareille. :clin:

C'est ligne cité plus haut sont demander dans le fichier installation du mod en question.

Avatar du membre

zach
Support phpBB Assistance
Support phpBB Assistance
Messages : 1313
Enregistré le : décembre 2010

Re: [Rules_page-V 1_0_1]Problème trouver via debug phpbb !

Message par zach » mer. 11 avr. 2012 19:51

Ce n'est pas parceque c'est dans un mod que ca ne peut pas provoquer d'erreur, remet le fichier faq.php d'origine pour tester

Verrouillé

Retourner vers « Mods indépendants de la base »