Image en bas de l'ecran

Image Forum de support général
Répondre
     
Avatar du membre

Auteur du sujet
fpoli75
Messages : 1123
Enregistré le : février 2012
Hébergeur(s) : Monarobase (et heureux!)
Localisation : IDF

Image en bas de l'ecran

Message par fpoli75 » jeu. 1 nov. 2012 09:29

Salut!
J'ai un debut de script qui affiche une image (calque) en bas de l'ecran et ce quelque soit la position de l’ascenseur.
L'image se depace en fonction de l'ascenseur.

Le probleme, c'est que c'est mal expliqué pour un rookie comme moi.
J'ai ca pour le moment:

Ajouter cette ligne dans l'index du forum:

Code : Tout sélectionner

<img id='id_de_limage' src='/chemin_de_limage.png'>
Modifier le css:

Code : Tout sélectionner

#id_de_limage
{
                position  :              absolute;   //pour la placer par rapport à la fenêtre du navigateur
                width      :              100%;       // sur toute la largeur de la page.
                bottom   :               0;             // alignée sur le bas de la fenêtre.
                height    :              25%;         //l'image occupe 25% de la hauteur de la page.
                margin   :              0;              //pas de marge extérieure
                padding :              0;              // ni intérieure
                z-index  :              2;         // position du calque (+grand au premier plan, donc mettre 20.)
                overflow:              hidden;     // pas de scrollbar non mais!
}
Ma question est que je ne sais pas quel est le ficher de l'index du forum et quel est le CSS?
peut etre "common.css" ?
pour l'image ID, comment savoir si l'ID que je vais prendre est pas utilisée ?
je peux prendre par exemple 99?

Si vous avez mes reposes.... Merci! :Peace:

Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10863
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: Image en bas de l'ecran

Message par Steph » jeu. 1 nov. 2012 09:34

Image
Information
-- Topic déplacé par Steph dans le bon forum --
Salut,

Pas de rapport direct avec phpbb donc je déplace

Pour l'ID tu mets ce que tu veux pas besoin que ce soit un numéro, mets "image_bas_ecran" ça conviendra et je doute qu'il existe déjà.

Sinon pour le css place ton code a la fin de colour.css vu que ça touche au graphisme

:clin:

Avatar du membre

Auteur du sujet
fpoli75
Messages : 1123
Enregistré le : février 2012
Hébergeur(s) : Monarobase (et heureux!)
Localisation : IDF

Re: Image en bas de l'ecran

Message par fpoli75 » jeu. 1 nov. 2012 09:45

ok, donc pour Colour.CSS, et pour le fichier de l'index? c'est lequel?
J'ai mis cette ligne dans index.html (qui etait vide au passage) ca n'a rien fait!
Merci Steph

Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10863
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: Image en bas de l'ecran

Message par Steph » jeu. 1 nov. 2012 09:52

Ah oui j'ai oublier de te le donner, c'est index_body.html

Avatar du membre

Auteur du sujet
fpoli75
Messages : 1123
Enregistré le : février 2012
Hébergeur(s) : Monarobase (et heureux!)
Localisation : IDF

Re: Image en bas de l'ecran

Message par fpoli75 » jeu. 1 nov. 2012 10:00

bon... je viens de le faire et ca m'a planté mon Theme! ca marche pas!
J'ai rajouté en 1ere position la ligne dans l'index body.

par contre, j'ai rajouté la ligne code du CSS vers les 3/4.
peut etre qu'il y a une position a respecter?

Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10863
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: Image en bas de l'ecran

Message par Steph » jeu. 1 nov. 2012 10:22

fpoli75 a écrit : bon... je viens de le faire et ca m'a planté mon Theme! ca marche pas!
J'ai rajouté en 1ere position la ligne dans l'index body
C'est en background que tu souhaite ça ? Si oui il faut agir autrement en passant directement par le css
fpoli75 a écrit : bpar contre, j'ai rajouté la ligne code du CSS vers les 3/4.
peut etre qu'il y a une position a respecter?
Pas de position à respecter

Avatar du membre

Auteur du sujet
fpoli75
Messages : 1123
Enregistré le : février 2012
Hébergeur(s) : Monarobase (et heureux!)
Localisation : IDF

Re: Image en bas de l'ecran

Message par fpoli75 » jeu. 1 nov. 2012 10:58

En modifiant COLOURS.CSS pour rajouter les lignes de code, ca a planté le theme.
J'ai viré ces lignes pour retrouver le theme fonctionnel.

En fait, j'aimerai afficher cette image en 1er plan en bas de la fenêtre d'IE/firefox.


Sur certains sites, les publicités s'affichent comme ca.
un exemple ici:
http://www.universfreebox.com/
Quand je regarde, je vois une pub GROUPON en bas qui se deplace en meme temps que l’ascenseur d'IE.
(peut etre qu'elle aura disparue quand tu regarderas)

Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10863
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: Image en bas de l'ecran

Message par Steph » jeu. 1 nov. 2012 11:18

fpoli75 a écrit : En modifiant COLOURS.CSS pour rajouter les lignes de code, ca a planté le theme.
J'ai viré ces lignes pour retrouver le theme fonctionnel.
Alors place ton code en bas du fichier et fait attention qu'il y a bien le ; a la fin de chaque ligne et que les instructions se trouvent entre les crochets { et }

Ensuite enlève les commentaires de chaque ligne, c'est source de conflit
fpoli75 a écrit : Quand je regarde, je vois une pub GROUPON en bas qui se deplace en meme temps que l’ascenseur d'IE.
(peut etre qu'elle aura disparue quand tu regarderas)
Oui en fait tu veux une boite qui reste au même endroit pendant le scrol de la page ?

Avatar du membre

Auteur du sujet
fpoli75
Messages : 1123
Enregistré le : février 2012
Hébergeur(s) : Monarobase (et heureux!)
Localisation : IDF

Re: Image en bas de l'ecran

Message par fpoli75 » jeu. 1 nov. 2012 12:02

voila, ca marche Mais!
mon image se met bien en bas de la page, par contre, la fonction "position : absolute;" ne semble pas fonctionner..
l'image bouge avec le forum, elle est comme collée.

Avatar du membre

Auteur du sujet
fpoli75
Messages : 1123
Enregistré le : février 2012
Hébergeur(s) : Monarobase (et heureux!)
Localisation : IDF

Re: Image en bas de l'ecran

Message par fpoli75 » jeu. 1 nov. 2012 12:46

bon, apres avoir googlé a fond, j'ai remplacé Absolute par Fixed et ca fonctionne bien.
:)

Répondre

Retourner vers « Support général »