[Support] BBCodes Box 3 Avancés

Image Forum de support des mod's .
Image Demande de personnalisation interdite
Verrouillé
     
Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10766
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: [Support] BBCode Box 3 Avancé 3.0.8-PL2

Message par Steph » jeu. 30 juin 2011 18:40

Bein de rien :clin:

Avatar du membre

Chuchulain
Messages : 7
Enregistré le : novembre 2011

Re: [Support] BBCodes Box 3 Avancés 3.0.9.3

Message par Chuchulain » mer. 2 nov. 2011 16:50

Bonjour !

J'ai installé le mod "advanced_bbcode_box_3_3_0_9_3" sur le nouveau forum que j'ai développé pour ma guilde "http://www.phenix-aoc.fr/", j'en suis très satisfait et tout fonctionne correctement mis à part un tout petit bug d'affichage sur les liens. Ce bug se produis quand on ajoute un lien sur une image comme vous pouvez le voir sur l’image ci-dessous ou sur un texte mis en couleur comme dans l'exemple de code suivant :

Code : Tout sélectionner

[url=http://www.phenix-aoc.fr/][color=#0000FF]mon lien bleu[/color][/url]
Résultat : mon lien bleu" class="postlink">mon lien bleu

Lien sur image :
Image

J'en ai déduis qu'il dois y avoir une variable qui est incrémentée avant la parenthèse qui apprêt ici ->"<- class="postlink"> et qu'il dois manquer une fonction php de type stripslashes quelque part, ce qui provoque le fin prématurée de la fonction qui incrémente la variable. J'ai passé de longues heures à parcourir le code de long en large, mais je n'ai pas trouvé l'origine du problème. J'imagine que je ne dois pas être le premier à qui ça arrive, mais je n'ai trouvé aucun forum qui faisait référence à ce bug. En parcourant le code j'ai remarqué que le bbcode pour les liens edonkey utilisait la même syntaxe et j'ai pensé qu'il pouvais y avoir un conflit avec la fonction des liens standards, mais là encore je n'ai pas trouver de solution.

Auriez vous déjà rencontrer ce bug ? Avez vous une solution à me proposer ?

Merci !
:vivepa:

Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10766
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: [Support] BBCodes Box 3 Avancés 3.0.9.3

Message par Steph » mer. 2 nov. 2011 17:14

Salut et bienvenue,

La seule chose que je ne comprends pas c'est le pourquoi de l'utilisation de la couleur pour un lien sur une image ??

Par contre un compte test ou un lien vers une page ou l'on vois le résultat serait bienvenue.

Est-ce la même chose avec un simple lien texte ?

Avatar du membre

Chuchulain
Messages : 7
Enregistré le : novembre 2011

Re: [Support] BBCodes Box 3 Avancés 3.0.9.3

Message par Chuchulain » mer. 2 nov. 2011 18:21

Merci de la rapidité de votre réponse ;)
Je vous ai créé un accès pour réaliser vos essais :
Nom : testuser
Pass : testuser
Vous avez accès à la partie publique du forum et vous devriez pouvoir constater le problème pas vous même. Sur la page suivante vous pouvez constater que le bug se produis aussi bien sur les liens sur image dans les signatures que dans les réponses des utilisateurs : http://www.phenix-aoc.fr/bar-des-barbar ... -t225.html

Pour répondre à votre 1ère question : pourquoi de l'utilisation de la couleur pour un lien sur une image ??
Vous avez mélangé les deux exemples, le bug se produis avec les liens sur une image ET aussi avec les liens sur un texte en couleur !

Pour la 2ème question : Est-ce la même chose avec un simple lien texte ?
Non, le bug ne se produis pas sur un simple texte, il se produis uniquement quand la balise contiens une autre balise bbcode, que ... .gif[/img]
Text coloré
[epic1]mon texte épic[/epic1][/code]

Merci ! :clin:

Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10766
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: [Support] BBCodes Box 3 Avancés 3.0.9.3

Message par Steph » mer. 2 nov. 2011 18:40

Bizarre ton truc c'est depuis que tu as installé ce MOD ?

Tu as tester avec un style prosilver de base sans le MOD ?

Renvoi les fichiers du MOD et revois les modifications.

Avatar du membre

Chuchulain
Messages : 7
Enregistré le : novembre 2011

Re: [Support] BBCodes Box 3 Avancés 3.0.9.3

Message par Chuchulain » mer. 2 nov. 2011 21:15

Oui, le bug est apparus qu'après l'installation du mod !
J'ai testé sans le mod avec le prosilver de base et je n'ai pas ce bug !
J'utilisais le même template sans le mod sur mon ancien forum (également phpbb 3.0.9) et je n'avais pas ce bug non plus, donc j'imagine que mon template n'y est pour rien !
J'ai renvoyé tous les fichiers et j'ai revérifié toute la procédure d'installation, chaque ligne de code est à sa place !
J'ai eu beau chercher je n'ai pas trouvé d'explication, vous êtes mon dernier recours !
:TT:

Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10766
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: [Support] BBCodes Box 3 Avancés 3.0.9.3

Message par Steph » mer. 2 nov. 2011 21:28

Peut-être voir au niveau du fichier "bbcodes.html" sinon je ne vois pas trop

Avatar du membre

Chuchulain
Messages : 7
Enregistré le : novembre 2011

Re: [Support] BBCodes Box 3 Avancés 3.0.9.3

Message par Chuchulain » mer. 2 nov. 2011 22:47

J'ai testé avec le mod et avec un autre template de style prosilver et je n'ai pas le bug. Donc le problème viens bien de mon template, je vais vérifier le fichier bbcode.html des deux templates et voir si je trouve où est la différence !
Merci !
:vivepa:

Avatar du membre

Chuchulain
Messages : 7
Enregistré le : novembre 2011

Re: [Support] BBCodes Box 3 Avancés 3.0.9.3

Message par Chuchulain » mer. 2 nov. 2011 22:55

Effectivement le problème était bien dans le fichier bbcode.html, il y avais (title="{DESCRIPTION}") dans la balise des liens, je l'ai supprimé et tout est rentré dans l'ordre !
Problème résolu, encore merci pour votre réactivité !
:dansmesbras:

Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10766
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: [Support] BBCodes Box 3 Avancés 3.0.9.3

Message par Steph » mer. 2 nov. 2011 23:23

:!: Merci d'éviter les doubles posts , passez plutôt par l'édition du dernier message .
L'édition de celui ci passera le topic comme non lu :clin:
Content d'avoir pu te mettre sur la piste :clin:

Verrouillé
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Retourner vers « Support Mods Bdd »