Ralentissement sur Mon Forum

Image Toutes les questions en rapport à l'utilisation de phpbb3 uniquement .
Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10740
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: Ralentissement sur Mon Forum

Message par Steph » dim. 6 mars 2011 23:24

L'hebergement d'images n'est pas en cause et le mod non plus car il fonctionne très bien ici et sur pcinfo, cela vient tout simplement de ton hébergeur qui est un peu lent et le fait qu'un autre site fonctionne bien n'y change rien car ce n'est pas forcément les meme script ni les meme demande au niveau fonctionnement.

Peut être regarder du coté du temps d'exécution d'un script qui serait régler trop court.

Pour les images je veux bien coder un truc qui permette de redimensionner les images mais elle seront modifier définitivement lors de l'envoi et je ne peux pas le faire de suite car cela demande un certains temps de codage


Auteur du sujet
S.Jordan
Messages : 205
Enregistré le : juin 2010
Hébergeur(s) : Xcluhosting
Localisation : Etudiant

Re: Ralentissement sur Mon Forum

Message par S.Jordan » dim. 6 mars 2011 23:44

Alors comment expliquer ce tels changements ?!? J'ai désinstaller le Mod est plus aucun ralentissements.

Va dessus tu verras Steph que je ment pas. Je pourrais donner la faut et de mon hébergeur seulement eurofreaks on + de 2000 membres + de 40000 messages et sont chez le même hébergeur que moi et ils ont aucun beug.

Sinon je laisse comme sa et puis c'est tous et je touche pu a rien tans que sa beug pas. je laisse image taille réelle et je demande à mes membres de loger les images en 640 comme sa ta rien besoin de faire Steph.

Merci co même de votre aide

Avatar du membre

EnYgmA
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 8634
Enregistré le : avril 2010
Hébergeur(s) : Monarobase
Localisation : Lyon
Contact :

Re: Ralentissement sur Mon Forum

Message par EnYgmA » lun. 7 mars 2011 05:59

Le mod c'est reimg_image_resizer ou Redimensionnement automatique :?:

Si tu as pris Redimensionnement automatique , le mod est hors de cause tellement le code est léger ... :^^:

Par contre si tu as l'autre je sais pas je l'ai jamais installé :clin:
Conditions générales de services - Conditions générales de support - C.G.U
Merci de mettre un titre de sujet explicite pour toutes vos demandes de support
Référencement gratuit - Forum informatique

Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10740
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: Ralentissement sur Mon Forum

Message par Steph » lun. 7 mars 2011 09:30

S.Jordan a écrit : Alors comment expliquer ce tels changements ?!? J'ai désinstaller le Mod est plus aucun ralentissements.

Va dessus tu verras Steph que je ment pas.
Je ne remet pas du tout en cause ce que tu avance mais tu confond le MOD et l'hébergement d'images, le MOD c'est le script que tu as modifié et/ou ajouté tandis que l'hébergement c'est simplement un service distant qui à part le temps de chargement de l'image suivant sont poids ne changera rien à la structure de tes fichiers donc pas de modifications niveau serrveur
S.Jordan a écrit : AJe pourrais donner la faut et de mon hébergeur seulement eurofreaks on + de 2000 membres + de 40000 messages et sont chez le même hébergeur que moi et ils ont aucun beug.
Même hébergeur ne veut pas dire même serveur car souvent ils en utilisent plusieurs avec des configurations différentes.
S.Jordan a écrit : je laisse image taille réelle et je demande à mes membres de loger les images en 640 comme sa ta rien besoin de faire Steph.
Ah mais cela ne me dérange pas d'améliorer selon les besoins et les possibilités seulement ce n'est pas toujours simple de le faire rapidement.

Sinon le second MOD donner par EnYgmA sur son dernier message ne demandera quasiment rien en ressource donc tu peux l'utiliser sans souci et au pire il n'est vraiment pas long à enlever donc tu ne perd rien à tester si ce n'est 10 minutes.

Tiens il me vient une idée pour voir comment est réglé le serveur de ton forum niveau php, créé un fichier à la racine que tu nomme phpinfo.php et au niveau contenu ajoute ceci

Code : Tout sélectionner

<?php
phpinfo();
?>
Ce fichier permettra d'accéder a une page avec l'information de tout les paramètres php te dirai si je vois quelque chose qui pourrai faire que tu ais une erreur 500 et tu ne risque rien

Avatar du membre

zach
Support phpBB Assistance
Support phpBB Assistance
Messages : 1313
Enregistré le : décembre 2010

Re: Ralentissement sur Mon Forum

Message par zach » lun. 7 mars 2011 12:11

Salut

Oui préciser quel mod tu utilise, et ou sont hébergées les images (interne/externe) voir une page d'exemple serait un plus pour identifier les causes possibles ...

sinon si une image extérieure met du tps à charger, elle pourrait ralentir ta page si le mod en question ne préciserait pas la taille de l'image width et height (le navigateur va devoir la charger pour déterminer la taille à afficher) je pense, mais c'est peu probable, vu que c'est le principe de ces mods de la préciser en redimensionnant


Auteur du sujet
S.Jordan
Messages : 205
Enregistré le : juin 2010
Hébergeur(s) : Xcluhosting
Localisation : Etudiant

Re: Ralentissement sur Mon Forum

Message par S.Jordan » lun. 7 mars 2011 12:20

Salut
Steph a écrit : Tiens il me vient une idée pour voir comment est réglé le serveur de ton forum niveau php, créé un fichier à la racine que tu nomme phpinfo.php et au niveau contenu ajoute ceci

Code : Tout sélectionner

<?php
phpinfo();
?>
Ce fichier permettra d'accéder a une page avec l'information de tout les paramètres php te dirai si je vois quelque chose qui pourrai faire que tu ais une erreur 500 et tu ne risque rien
Voila sa me donne cela : http://www.stf-transports.fr/phpinfo.php

Merci

Avatar du membre

zach
Support phpBB Assistance
Support phpBB Assistance
Messages : 1313
Enregistré le : décembre 2010

Re: Ralentissement sur Mon Forum

Message par zach » lun. 7 mars 2011 13:17

S.Jordan a écrit : Ce n'est pas l'hébergeur d'image mais le Mod qui créer un fort ralentissement du forum :meuh:
le mod ? sans vouloir insister, on ne sait tjrs pas de quoi de quel mod tu parle, donc difficile de savoir

t'a pas un exemple concret de page ralentie avec des images ?

Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10740
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: Ralentissement sur Mon Forum

Message par Steph » lun. 7 mars 2011 13:18

zach a écrit : et ou sont hébergées les images (interne/externe) voir une page d'exemple serait un plus pour identifier les causes possibles ...
C'est hébergé sur mon serveur donc en externe.
zach a écrit : sinon si une image extérieure met du tps à charger, elle pourrait ralentir ta page si le mod en question ne préciserait pas la taille de l'image width et height (le navigateur va devoir la charger pour déterminer la taille à afficher) je pense, mais c'est peu probable, vu que c'est le principe de ces mods de la préciser en redimensionnant
Je n'avais pas pensé a cette éventualitée mais effectivement si le MOD ne connais pas la taille il devra d'abord la déterminer pour ensuite calculer le nouveau ratio hauteur largeur donc le script mais plus de temps à travailler
S.Jordan a écrit : Voila sa me donne cela : http://www.stf-transports.fr/phpinfo.php
Dans l'ensemble la config me parai correct, seul le max_execution_time me parai peu bien que suffisant et si ton erreur apparait au bout de 30 secondes de chargement cela peut en être la cause.


Auteur du sujet
S.Jordan
Messages : 205
Enregistré le : juin 2010
Hébergeur(s) : Xcluhosting
Localisation : Etudiant

Re: Ralentissement sur Mon Forum

Message par S.Jordan » lun. 7 mars 2011 14:00

zach a écrit :
S.Jordan a écrit : Ce n'est pas l'hébergeur d'image mais le Mod qui créer un fort ralentissement du forum :meuh:
le mod ? sans vouloir insister, on ne sait tjrs pas de quoi de quel mod tu parle, donc difficile de savoir

t'a pas un exemple concret de page ralentie avec des images ?
J'avais donner un Exemple auparavant à Steph mais maintenant que j'ai enlever le mod j'ai plus de soucie.

Le mod que je parle en question est : http://www.phpbb-assistance.com/lien-ve ... 25-30.html
Steph a écrit :
S.Jordan a écrit : Voila sa me donne cela : http://www.stf-transports.fr/phpinfo.php
Dans l'ensemble la config me parai correct, seul le max_execution_time me parai peu bien que suffisant et si ton erreur apparait au bout de 30 secondes de chargement cela peut en être la cause.
Ok donc maintenant je peux supprimer le fichier à la racine ?

Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10740
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: Ralentissement sur Mon Forum

Message par Steph » lun. 7 mars 2011 15:02

Oui tu peux enlever le fichier phpinfo.php .

Et pour un autre MOD celui ci est beaucoup moins gourmand ---> Redimensionnement automatique

Verrouillé
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Retourner vers « Utilisation »