Comment mettre un fond en flash ?

Image Toutes les demandes de support touchant au style de votre forum.
Règles du forum
[Nom exact du style] Description de votre problème
Verrouillé
     
Avatar du membre

zach
Support phpBB Assistance
Support phpBB Assistance
Messages : 1313
Enregistré le : décembre 2010

Re: Comment mettre un fond en flash ?

Message par zach » mer. 27 avr. 2011 19:09

il faut regarder les options ...

Code : Tout sélectionner

<script type="text/javascript">  
			
			jQuery(function($){
				$.supersized({
				
					//Functionality
					slideshow               :   1,		//Slideshow on/off
					autoplay				:	1,		//Slideshow starts playing automatically
					start_slide             :   1,		//Start slide
					slide_interval          :   3000,	//Length between transitions
					transition              :   1, 		//0-None, 1-Fade, 2-Slide Top, 3-Slide Right, 4-Slide Bottom, 5-Slide Left, 6-Carousel Right, 7-Carousel Left
					transition_speed		:	500,	//Speed of transition
					new_window				:	1,		//Image links open in new window/tab
					pause_hover             :   0,		//Pause slideshow on hover
					keyboard_nav            :   1,		//Keyboard navigation on/off
					performance				:	1,		//0-Normal, 1-Hybrid speed/quality, 2-Optimizes image quality, 3-Optimizes transition speed // (Only works for Firefox/IE, not Webkit)

					//Size & Position
					min_width		        :   0,		//Min width allowed (in pixels)
					min_height		        :   0,		//Min height allowed (in pixels)
					vertical_center         :   1,		//Vertically center background
					horizontal_center       :   1,		//Horizontally center background
					fit_portrait         	:   1,		//Portrait images will not exceed browser height
					fit_landscape			:   0,		//Landscape images will not exceed browser width
					
					//Components
					navigation              :   1,		//Slideshow controls on/off
					thumbnail_navigation    :   1,		//Thumbnail navigation
					slide_counter           :   1,		//Display slide numbers
					slide_captions          :   1,		//Slide caption (Pull from "title" in slides array)
					slides 					:  	[		//Slideshow Images
														{image : 'http://buildinternet.s3.amazonaws.com/projects/supersized/3.1/slides/quietchaos-kitty.jpg', title : 'Quiet Chaos by Kitty Gallannaugh', url : 'http://www.nonsensesociety.com/2010/12/kitty-gallannaugh/'},  
														{image : 'http://buildinternet.s3.amazonaws.com/projects/supersized/3.1/slides/wanderers-kitty.jpg', title : 'Wanderers by Kitty Gallannaugh', url : 'http://www.nonsensesociety.com/2010/12/kitty-gallannaugh/'},  
														{image : 'http://buildinternet.s3.amazonaws.com/projects/supersized/3.1/slides/apple-kitty.jpg', title : 'Applewood by Kitty Gallannaugh', url : 'http://www.nonsensesociety.com/2010/12/kitty-gallannaugh/'}  
												]
												
				}); 
		    });
		    
		</script>
transition : 1, //0-None, 1-Fade, 2-Slide Top, 3-Slide Right, 4-Slide Bottom, 5-Slide Left, 6-Carousel Right, 7-Carousel Left

Avatar du membre

Auteur du sujet
Pro_info
Messages : 357
Enregistré le : avril 2011
Contact :

Re: Comment mettre un fond en flash ?

Message par Pro_info » jeu. 28 avr. 2011 09:56

Salut il semblerait que cela vienne de ie9 car avec mozilla je vois les images en fondu en fond de forum tandis qu'avec ie9 je ne vois que le gif loading et un fond noir.
Pourtant avec l'archive télécharger sur le site et les exemples sa onctionne très bien avec ie9 quelqu'un aurais t'il une solution pour faire le faire fonctionner sous ie9 ou même peut être un autre "mod". merci

Avatar du membre

Auteur du sujet
Pro_info
Messages : 357
Enregistré le : avril 2011
Contact :

Re: Comment mettre un fond en flash ?

Message par Pro_info » jeu. 28 avr. 2011 10:07

J'ai résolu mon problème on pourrait dire que c un coup de chance que j'ai trouvé sa.

je m'explique dans le fichier du mod j'ai regardé cette ligne

Code : Tout sélectionner

<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.5.0/jquery.min.js"></script>
je n'avais rien à perdre donc j'ai remplacé la version par la plus récente qui pouvais existé (1.5.1 ; 1.5.2 ; 1.5.3) j'ai vu que la plus récente était la 1.5.2 donc j'ai remplacé la ligne

Code : Tout sélectionner

<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.5.2/jquery.min.js"></script>
et voilà que la compatibilité avec ie9 fonctionne merci à vous j'ai enfin trouvé le moyen de mettre des images de fond en fondu à mon forum.
A++

Avatar du membre

Auteur du sujet
Pro_info
Messages : 357
Enregistré le : avril 2011
Contact :

Re: Comment mettre un fond en flash ?

Message par Pro_info » dim. 1 mai 2011 15:04

je vien de découvrir un problème lorsque je vais dans le profil que je clic sur "aperçu" "profil" "préférence..." et bien lorsque je veux cliqué sur une des sous catégorie sa ne fonctionne pas j'ai essayer en supprimant le code du overall_header sa fonctionne de nouveau j'ai essayer de déplacé le code en le mettant dans overall_footer (il est lui aussi utilisé pour toutes les pages) sa ne fonctionne pas pour tant je vois bien le lien lorsque je passe la souris dessus auriez vous une solution à me proposé ?

si vous voulez tester je créé un compte test pseudo : test mdp : testtest

Avatar du membre

zach
Support phpBB Assistance
Support phpBB Assistance
Messages : 1313
Enregistré le : décembre 2010

Re: Comment mettre un fond en flash ?

Message par zach » dim. 1 mai 2011 15:32

en tout cas lorsque je teste les sous catégories du profil la seule qui bug est "aperçu", toutes les autres sont ok

Avatar du membre

Auteur du sujet
Pro_info
Messages : 357
Enregistré le : avril 2011
Contact :

Re: Comment mettre un fond en flash ?

Message par Pro_info » dim. 1 mai 2011 19:02

bizzard pourtant je viens de réessayer et j'ai le problème sur toutes sans exception

Avatar du membre

zach
Support phpBB Assistance
Support phpBB Assistance
Messages : 1313
Enregistré le : décembre 2010

Re: Comment mettre un fond en flash ?

Message par zach » dim. 1 mai 2011 20:51

difficile à dire, surement un prb de script qui doit interférer,

tu aura surement + vite fait de changer, que de trouver le pbl

par exemple http://www.marcofolio.net/webdesign/adv ... eshow.html

Avatar du membre

Auteur du sujet
Pro_info
Messages : 357
Enregistré le : avril 2011
Contact :

Re: Comment mettre un fond en flash ?

Message par Pro_info » lun. 2 mai 2011 15:44

c'est quand même dommage de remplacé ce mod car il est très bien n'y a t-il pas un moyen de modifier plutôt le problème dans le style ?

édit : sa n'est pas dit qu'en changent de "mod" sa fonctionne mieux car tous utilise "jquery" pour la transition ( http://jquery.com/ )

Avatar du membre

zach
Support phpBB Assistance
Support phpBB Assistance
Messages : 1313
Enregistré le : décembre 2010

Re: Comment mettre un fond en flash ?

Message par zach » mar. 3 mai 2011 04:10

n'y a t-il pas un moyen de modifier plutôt le problème dans le style ?
c'est surement un nom qui doit etre utilisé par ce script et d'autres, du coup les scripts s'interfèrent, tu peut toujours chercher, epluche tous les scripts phpbb + ceux la pour trouver le prb ...

edit : allez je t'aide, regarde du coté des 2 "#navigation" dans supersized.js
sa n'est pas dit qu'en changent de "mod" sa fonctionne mieux car tous utilise "jquery" pour la transition
jquery est une "librairie" qui est utilisée par des scripts, en soit ca ne peut pas poser de prb, je ne pense pas vu que j'utilise jquery aussi pour d'autres scripts sur phpbb (comme beaucoup de site phpbb), et je n'ai jamais vu ce prb pour autant,

t'a qu'a laisser la ligne de script jquery, et enlever les autres scripts, tu verra si c'est ca ou pas ... si tes liens marchent ce sera donc du au retrait du script lui meme et pas de jquery

Avatar du membre

Auteur du sujet
Pro_info
Messages : 357
Enregistré le : avril 2011
Contact :

Re: Comment mettre un fond en flash ?

Message par Pro_info » mar. 1 mai 2012 09:04

edit : allez je t'aide, regarde du coté des 2 "#navigation" dans supersized.js
tu es un génie zach un petit conflit "tout con" j'ai fais une recherche dans le dossier du style est j'ai vu que "#navigation" était également utilisé dans les fichiers "theme\cp.css" et dans "theme\colour.css" j'ai donc remplacer (dans le fichier supersized.js) tout les "navigation" par "navigation1" pour ainsi supprimé le conflit et sa fonctionne impecc maintenant merci à toi Zach

Verrouillé

Retourner vers « Support Styles phpBB3 »