Fonction "Imprimer le sujet" ne fonctionne pas.

Image Toutes les questions en rapport à l'utilisation de phpbb3 uniquement .
Verrouillé
     
Avatar du membre

Auteur du sujet
Sille
Membre Tranquility
Membre Tranquility
Messages : 4310
Enregistré le : mai 2011
Hébergeur(s) : mon@robase.net c'est clair et net !
Localisation : Au dessus de la Seine et de la Marne.
Contact :

Fonction "Imprimer le sujet" ne fonctionne pas.

Message par Sille » ven. 13 mai 2011 13:58

Bonjour à toutes et tous,

la fonction "imprimer le sujet" ne fonctionne pas. Y a-t-il un réglage ou une activation à faire préalablement.

J'ai fait des essais concluants sur des forums phpbb. On y voit bien la page changer en noir et blanc. Chez moi, rien, de n'importe quel navigateur et/ou ordinateur. Je n'ai qu'une actualisation :grrr:

Je n'ai encore rien trouvé, merci pour votre aide.

Cordialement, Sille.
>> Solutions et Services PhpBB
>> Communauté Graphique

Soutenir >> Image

[6 ans de Pack] Image ici

Déjà 5 ans chez mon@robase.net Image Image

Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10963
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: Fonction "Imprimer le sujet" ne fonctionne pas.

Message par Steph » sam. 14 mai 2011 01:42

Salut,

Je viens d'analyser le fichier mis en cause et j'ai trouvé d’où vient le souci, seulement si je le corrige je crains que tes fiches ne fonctionnent plus car c’est lié à la modification les concernants

Nous ferons quelques essais demain matin

En gros dans ton fichier viewtopic.php tu as ça

Code : Tout sélectionner

$template->set_filenames(array(
	'body' => ($dans_fiche) ? 'viewfiche_body.html' : 'viewtopic_body.html')
);
Alors que le code réel dois être ça

Code : Tout sélectionner

$template->set_filenames(array(
	'body' => ($view == 'print') ? 'viewtopic_print.html' : 'viewtopic_body.html')
);
Le script n'accède plus au template concernant la page du sujet pour impression donc il renvoi à l'origine

J'ai testé et ça fonctionne par contre pour être sur que cela n’affecte pas les fiches j'ai besoin de savoir comment tu les rédiges car je ne crois pas que j'ai les droits nécessaires.

Au fait merci pour les corrections :clin:

Avatar du membre

Auteur du sujet
Sille
Membre Tranquility
Membre Tranquility
Messages : 4310
Enregistré le : mai 2011
Hébergeur(s) : mon@robase.net c'est clair et net !
Localisation : Au dessus de la Seine et de la Marne.
Contact :

Re: Fonction "Imprimer le sujet" ne fonctionne pas.

Message par Sille » sam. 14 mai 2011 08:39

Steph a écrit : Le script n'accède plus au template concernant la page du sujet pour impression donc il renvoi à l'origine

J'ai testé et ça fonctionne par contre pour être sur que cela n’affecte pas les fiches j'ai besoin de savoir comment tu les rédiges car je ne crois pas que j'ai les droits nécessaires.

Au fait merci pour les corrections :clin:
Bonjour,

alors là il faut un peu plus m'expliquer pour que je puisse te répondre :meuh:

Merci.
>> Solutions et Services PhpBB
>> Communauté Graphique

Soutenir >> Image

[6 ans de Pack] Image ici

Déjà 5 ans chez mon@robase.net Image Image

Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10963
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: Fonction "Imprimer le sujet" ne fonctionne pas.

Message par Steph » sam. 14 mai 2011 10:28

En fait prenons le code présent dans ton cas

Code : Tout sélectionner

$template->set_filenames(array(
   'body' => ($dans_fiche) ? 'viewfiche_body.html' : 'viewtopic_body.html')
);
L'action est fonction de la valeur de la variable $dans_fiche qui indique soit oui soit non en fonction de la situation, si c'est oui le script utilisera le template d'affichage viewfiche_body.html si non il utilisera viewtopic_body.html

Hors pour l'impression des sujet il faut le template viewtopic_print.html qui n'existe plus dans ton fichier puisqu'il à été remplacé

Bref j'ai modifier donc regarde si ça fonctionne pour l'affichage d'un sujet, pour la page d'impression et si tu n'as pas de souci avec tes fiches

Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10963
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: Fonction "Imprimer le sujet" ne fonctionne pas.

Message par Steph » mer. 18 mai 2011 21:30

Salut,

As-tu testé ?
Si le problème est considéré comme réglé

Merci de passer ton topic en "Image" à l'aide de l'attribut [Résolu].

A bientôt :clin:[/b][/size]

Avatar du membre

Auteur du sujet
Sille
Membre Tranquility
Membre Tranquility
Messages : 4310
Enregistré le : mai 2011
Hébergeur(s) : mon@robase.net c'est clair et net !
Localisation : Au dessus de la Seine et de la Marne.
Contact :

Re: Fonction "Imprimer le sujet" ne fonctionne pas.

Message par Sille » jeu. 19 mai 2011 12:49

Bonjour Steph,

désolé je n'avais pas vu le
Bref j'ai modifier donc regarde
Donc sur un ordi avec FF et XP pour les sujets cela semble correct (je vais tester aussi chez moi), le page s'affiche pour une impression (le style disparait). Par contre l'impression s'engage seule ou une fenêtre de commande doit s'ouvrir ? Ici je n'ai rien (idem, je vais tester chez moi, je connais mieux les machines).


Pour les fiches un souci :
Not Found

The requested URL /topic714.html&view=print was not found on this server.
Par contre tu m'avais conseillé de tout bouger dans un forum "invisible" afin d'être scannées par les robots. Je n'ai pas encore fait :meuh: Si cela n'a pas d'incidence tu peux donc regarder car je m'y mets ce soir seulement.

Merci.
>> Solutions et Services PhpBB
>> Communauté Graphique

Soutenir >> Image

[6 ans de Pack] Image ici

Déjà 5 ans chez mon@robase.net Image Image

Avatar du membre

Steph
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 10963
Enregistré le : avril 2010
Hébergeur(s) : monarobase
Localisation : Alsace (67)
Contact :

Re: Fonction "Imprimer le sujet" ne fonctionne pas.

Message par Steph » jeu. 19 mai 2011 13:43

Sille a écrit : Par contre l'impression s'engage seule ou une fenêtre de commande doit s'ouvrir ? Ici je n'ai rien (idem, je vais tester chez moi, je connais mieux les machines).
En fait c’est une page sans style qui supprime beaucoup de chose comme la couleur de fond certaines images qui ne servent à rien ou encore la barre de navigation afin d'alléger la page, cependant l'impression se fait comme tout autre document c'est à dire soit la commande Fichier > Imprimer ou alors Ctrl+P du clavier.

Rien d'automatique ou d'extraordinaire
Sille a écrit : Pour les fiches un souci :
Not Found

The requested URL /topic714.html&view=print was not found on this server.
C'est réglé !

En fait c'étais lié au fait que tu utilise un fichier qui n'est pas de base sur phpbb donc il fallait adapter le lien
Sille a écrit : Par contre tu m'avais conseillé de tout bouger dans un forum "invisible" afin d'être scannées par les robots. Je n'ai pas encore fait :meuh: Si cela n'a pas d'incidence tu peux donc regarder car je m'y mets ce soir seulement.
Vaut mieux ouvrir un nouveau sujet, toujours dans le cadre d'un bon suivi de ton forum :clin:

Avatar du membre

Auteur du sujet
Sille
Membre Tranquility
Membre Tranquility
Messages : 4310
Enregistré le : mai 2011
Hébergeur(s) : mon@robase.net c'est clair et net !
Localisation : Au dessus de la Seine et de la Marne.
Contact :

Re: Fonction "Imprimer le sujet" ne fonctionne pas.

Message par Sille » jeu. 19 mai 2011 17:36

Merci pour tout Steph :n°1:

Pro, comme d'hab :clin:

(en plus j'apprends, c'est ce que je souhaite surtout)

je réalise les tests ce soir et je valide.

Merci.
>> Solutions et Services PhpBB
>> Communauté Graphique

Soutenir >> Image

[6 ans de Pack] Image ici

Déjà 5 ans chez mon@robase.net Image Image

Avatar du membre

EnYgmA
Administrateur phpBB Assistance
Administrateur phpBB Assistance
Messages : 8650
Enregistré le : avril 2010
Hébergeur(s) : Monarobase
Localisation : Au soleil
Contact :

Re: Fonction "Imprimer le sujet" ne fonctionne pas.

Message par EnYgmA » lun. 23 mai 2011 10:01

Si le problème est considéré comme réglé

Merci de passer ton topic en "Image" à l'aide de l'attribut [Résolu].

A bientôt :clin:[/b][/size]
Très absent en ce moment ...
Conditions générales de services - Conditions générales de support - C.G.U
Merci de mettre un titre de sujet explicite pour toutes vos demandes de support
Référencement gratuit - Forum informatique

Avatar du membre

Auteur du sujet
Sille
Membre Tranquility
Membre Tranquility
Messages : 4310
Enregistré le : mai 2011
Hébergeur(s) : mon@robase.net c'est clair et net !
Localisation : Au dessus de la Seine et de la Marne.
Contact :

Re: Fonction "Imprimer le sujet" ne fonctionne pas.

Message par Sille » lun. 23 mai 2011 12:20

Oui ce soir, promis :clin:
>> Solutions et Services PhpBB
>> Communauté Graphique

Soutenir >> Image

[6 ans de Pack] Image ici

Déjà 5 ans chez mon@robase.net Image Image

Verrouillé
  • Sujets similaires
    Réponses
    Vues
    Dernier message

Retourner vers « Utilisation »